The Security Corporation claims to have identified a flaw affecting Apple's QuickTime/Darwin Streaming Server software.

This affects the software running on OS X (QuickTime Streaming Server), Win32 and Linux systems.

Several vulnerabilities have been identified in the software, including denial of service, Web root traversal and script source disclosure.

Apple has already released fixes for the majority of these problems. The security company recommends that users upgrade to version 4.1.3g or later of Darwin Streaming Server in response. The company offers no information for a potential patch for QuickTime Streaming Server systems.