Adobe has issued a security warning for Adobe Reader users on Linux, Solaris, HP-UX and IBM-AIX systems.

The warning has not been issued for Adobe Reader users working on Mac or Windows systems.

A note on the company's website warns of a vulnerability that: "Under certain circumstances, remote exploitation of a buffer overflow in Adobe Reader could allow an attacker to execute arbitrary code".

The company recommends users on affected platforms to download and use Adobe Reader 5.0.9, 5.0.10 or 5.0.11.

More information is available on the company's Web support pages.